MP3-Boss forum

Questions, comments and concerns about MP3-Boss: MP3 Database and Manager

You are not logged in.

Announcement

MP3-Boss Facebook Group
v0.683 is the official release. * Beta info * Have you checked the MP3-Boss Facebook Page? My contact address is MP3-Boss primary email address.
Returning users: Send me an email containing your user name, and I'll reset your email address (old info was lost during a crash).

#1 2008-08-13 22:07:07

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Any problems with v0.667?

Let me know if you find any problems with v0.667.  Since this is a minimal change bugfix release, I plan to make it the official release in a few days if it looks good...

Thanks for your help!

Offline

 

#2 2008-08-19 06:53:31

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

When I start mp3-list view, after 6 seconds I get the message: "Unable to locate mp3 player ... "
Winamp starts but does not connect to mp3-boss.

Playertimeout: 25 seconds

I close mp3-boss and Winamp
Restart Winamp before starting mp3-boss.
Restart Mp3-boss - listview - works.

Offline

 

#3 2008-08-21 21:57:25

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

I'll take a look.  How long does it actually take for Winamp to load?  It sounds like the problem is simply that MP3-Boss isn't waiting the 25 seconds before giving up?

Offline

 

#4 2008-08-23 18:56:59

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

It seems so. Loading winamp takes about 3-5 seconds.

I think, that I found an other failure too.
Select some entrys in mp3list - Click on delete - and choose dell selected files (selected checked only) - does not work

My installed version 0.667. When I start mp3-boss the first time day, i get tthe ask: "update version" and "..update datatable.."
I already have the latestr version, havenīt I?

Offline

 

#5 2008-08-24 04:14:26

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

Try:
Start/Programs/MP3Boss/Optimize Data and Optimize Database

...to make sure that the tables aren't corrupted.

I'll take a look at the "Delete selected files" problem.

Offline

 

#6 2008-08-27 22:26:05

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

I optimized but it didnīt changed anything.

If it ist important for you: The version I should update to is version 0665.

Harald

Offline

 

#7 2008-08-28 23:28:30

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

Are you asked to update to a new version (and datatable) every day?

Did you see this problem with any earlier versions?

Offline

 

#8 2008-08-30 15:12:11

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

Yes, Iīm asked every day.

I saw this problem within earlier versions too, but I donīt know, when it was showed for the first time.

harald

Offline

 

#9 2008-08-31 05:35:27

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

My guess is that I'm checking the date incorrectly.  What Regional Settings/Date Format are you using?

Anyone else seeing this same problem?

Offline

 

#10 2008-08-31 05:53:04

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

?

31.10.2008, GMT +01:00

Harald

Offline

 

#11 2008-09-13 08:37:49

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

What are the settings for Configuration/More/Auto-Check for Updates (near bottom of dialog)?

The default settings are:
7 days, ask before checking

Offline

 

#12 2008-09-13 10:09:38

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

The setting was :never check for uptdates.
Now I set to default.

Offline

 

#13 2008-09-13 11:19:04

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

That was the problem -- I looked at my code, and if it was 'Never Check' -- it would check every time.

Fixed next release.

Offline

 

#14 2008-09-14 03:12:27

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

super

Did you find something out about the winamploadingproblem?

Offline

 

#15 2008-09-14 04:15:42

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

What version of Winamp are you using?

Where is Winamp located on you system (e.g., c:\program files\winamp\winamp.exe)?

Did loading Winamp work OK in older versions of MP3-Boss?

The just-release v0.668 beta adds some error logging to that section of the code, plus does a little to cleanup loading Winamp.

Offline

 

#16 2008-09-14 11:46:13

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

Winamp version 5.541
directory: C:\installierungen\software\player\winamp\version\554
I have to try but I think in 551 or so the winamp loading was correct.

Harald

Offline

 

#17 2008-09-14 14:16:26

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

I just installed Winamp v5.541, and at least here MP3-Boss will load it correctly (default timeout of 10s).  I'm using the just-released beta v0.668.

Is the "Player Location" (first tab of MP3-Boss Configuration) correct?

New info:
I'm able to see the problem on my VISTA computer.  Are you using VISTA?  Under VISTA, I get the message:
Unable to locate the MP3 player: c:\program files\winamp\

If I go to configuration and (re-)select the winamp player path, I get:
Unsupported MP3 Player. Please select a different MP3 Player in configuration.

...followed by:
The Winamp playlist is not in the location specified by paths.ini
c:\users\John\AppData\Roaming\Winamp\winamp.m3u

When I bring up List View, the player controls indicates "Winamp unavailable"  ... but actually controllable (including bringing up the playlist!)

Let me know if this sounds similar to the problem you are seeing.  Hopefully I can track this down quickly.

Offline

 

#18 2008-09-15 03:53:26

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

I have Vista.
Yes this sounds similar to my problem.


Some controlls are not available (forward, rewind, shuffle)

If you start Winamp first, play on a song, then start mp3boss and listview, and all controlls are working.

The player location is correct.

Last edited by HaraldF (2008-09-15 03:54:09)

Offline

 

#19 2008-09-15 16:22:50

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

Once I exited and restarted MP3-Boss v0.668 -- Winamp seems to start OK every time (this is under VISTA).  Rebooting...and Winamp still loads fine.

Can you try the v0.668 beta and let me know if it helps?

Thanks!

Anybody else seeing this problem?

Offline

 

#20 2008-09-16 01:00:18

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

In version 0668 it is the same like in 0667.

Harald

Offline

 

#21 2008-09-16 02:00:35

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

Please send me your mp3boss.log file.

Offline

 

#22 2008-09-17 09:21:12

HaraldF
Member
Registered: 2011-06-05
Posts: 139

Re: Any problems with v0.667?

send you the file

From Harald Fink Tue Sep 16 23:11:58 2008
Received: from [88.116.168.106] by web53911.mail.re2.yahoo.com via HTTP; Tue, 16 Sep 2008 23:11:58 PDT
Date: Tue, 16 Sep 2008 23:11:58 -0700 (PDT)
From: Harald Fink <fharald@yahoo.com>
Subject: mp3boss.log
To: john <mccaffjt@newsguy.com>

Offline

 

#23 2008-09-18 04:05:20

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Any problems with v0.667?

I received the log -- the error was trapped:
"NoWinAmp: (76) Path not found"

For the next release, I'll add some additional error log information when the winamp can't be found.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB