MP3-Boss forum

Questions, comments and concerns about MP3-Boss: MP3 Database and Manager

You are not logged in.

Announcement

MP3-Boss Facebook Group
v0.683 is the official release. * Beta info * Have you checked the MP3-Boss Facebook Page? My contact address is MP3-Boss primary email address.
Returning users: Send me an email containing your user name, and I'll reset your email address (old info was lost during a crash).

#1 2005-04-04 10:36:22

yahs
Member
Registered: 2011-06-05
Posts: 63

Calculating . . .

John,
I turned on the MM:SS option in the length field and I now get the recalculating message every time I click in a field. It disappears when I switch the time option off.
SK

Offline

 

#2 2005-04-04 11:43:46

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

yahs wrote:

John,
I've sent an email with the error mesage and a screen shot.

I turned on the MM:SS option in the length field and I now get the recalculating message every time I click in a field. It disappears when I switch the time option off.
SK

I see that "Calculating..." message too -- but it does it slow things down for you?

I'll see if there is anything I can do.

Offline

 

#3 2005-04-05 16:20:00

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

The "Calculating . . ." message seems to occur for either mode (MM:SS or SSSS), but is sometimes off after switching modes.  Since it doesn't always occur, I'm not sure that I have any control. 

It looks like it happens if I haven't explicitly set the statusbar text...so if you change the configuration and the status now says "INI changed" the message goes away until the next time I clear the statusbar.

I've changed the code a bit to make sure that when you are in MM:SS mode it doesn't try to display MM:SS on the statusbar.  Also, I've fixed it so that SSSS now REALLY shows MM:SS on the statusbar when you click that field.

Offline

 

#4 2005-04-06 11:18:48

yahs
Member
Registered: 2011-06-05
Posts: 63

Re: Calculating . . .

John,
Got the e-mail, thanks.
I had a few comments on upgrade v 0.593 which you replied to and you did something to fix the screen so that the "calculating.." message disapppeared.
It doesn't seem to slow the program down, but I can't help but notice the message when I am moving around different fields and records.

SK

Offline

 

#5 2005-04-06 12:52:58

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

yahs wrote:

John,
Got the e-mail, thanks.
I had a few comments on upgrade v 0.593 which you replied to and you did something to fix the screen so that the "calculating.." message disapppeared.
It doesn't seem to slow the program down, but I can't help but notice the message when I am moving around different fields and records.

SK

In v0.593, the screen took a very long time to update when in MM:SS mode...you could actually see the MM:SS results get calculated when you scrolled the screen.

Now, you only see the "Calculating..." message when you click to a new record.

Try this:
1) Close List View
2) Open Configuration and get rid of the [] MM:SS checkbox
3) Click OK
...now when you open List View, you don't see the "Calculating ... " message, unless you do something (like clicking in the Length field) that causes the status bar to update.  Once you get the "Calculating . . . " message, it comes up every time you move to a new record.  Notice you don't see it if you click within a single record.

Now, repeat steps 1 - 3, but click the [] MM:SS checkbox.

...once again you won't see the "Calculating . . . " message until you do something that causes it to start (like clicking on Length).  In the next revision, I've changed it so clicking on Length won't try to update the status bar when you are in MM:SS mode.

It looks like the "Calculating . . ." message is totally out of my control, unless I get rid of all the status bar messages that describe the current field.

I have to admit that I don't understand why we are seeing it now, but not before.  Is it possible we just didn't notice it?

Offline

 

#6 2005-04-10 05:34:29

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

Definitely the "Calculating..." message is a side effect of having the List View update the statusbar.  I can remove the problem by simply blanking the statusbar before bringing up List View.

The question is...should I blank it out, or continue to show the field information in the statusbar?  If the field information only rarely shows up...perhaps I should eliminate it entirely?

Offline

 

#7 2005-04-11 11:09:43

yahs
Member
Registered: 2011-06-05
Posts: 63

Re: Calculating . . .

John,
I rolled back through various versions since 0.57 and I think the answer is that yes I just didn't notice the status bar refreshing.
From my point of view, I don't really use the messages on the status bar so I wouldn't mind if the info wasn't there.

Is it just me or does the scroll button not work in list view ?

SK

Offline

 

#8 2005-04-11 12:18:28

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

yahs wrote:

John,
I rolled back through various versions since 0.57 and I think the answer is that yes I just didn't notice the status bar refreshing.
From my point of view, I don't really use the messages on the status bar so I wouldn't mind if the info wasn't there.

Is it just me or does the scroll button not work in list view ?

SK

To turn off the messages completely, it looks like I probably would need to set the status bar to " " on a timer.  If I simply remove all the status information from all the List View fields, the status message "Form View" appears.

I don't understand why the statusbar information doesn't always appear.  The "Calculating . . ." message seems to be an Access bug, since the update is fast enough that throwing another message on the screen shouldn't have been necessary.

Scroll Button

Do you mean the Scrollwheel on your mouse?  Or really the scroll bar isn't working when you click it?  The scrollwheel is a function of the mouse driver you are using...there are a few workarounds (already covered in this forum -- you need either the 4.12 Intellipoint driver, or Freewheel, if you are using a real Microsoft mouse).

Offline

 

#9 2005-04-14 12:08:13

yahs
Member
Registered: 2011-06-05
Posts: 63

Re: Calculating . . .

John,

It's probably easier to leave the status messages, I don't really notice them (except for the calculating!!!). As you say there is no time delay anyway.

Thanks for the info on the mouse scroll, I just happened to restore an image file that didn't have my mouse driver installed.
SK

Offline

 

#10 2005-04-14 12:56:32

mccaffjt
Admin
Registered: 2011-06-05
Posts: 1295
Website

Re: Calculating . . .

yahs wrote:

John,

It's probably easier to leave the status messages, I don't really notice them (except for the calculating!!!). As you say there is no time delay anyway.

Thanks for the info on the mouse scroll, I just happened to restore an image file that didn't have my mouse driver installed.
SK

I don't notice the message either...except now I am annoyed by the "Calculating . . ." message! LOL

If I get a chance, I might see if I can set the message in code instead of relying on Access to show the statusbar.  If I set it to " ", it is usually quite a long time until you see the messages again (e.g., after scanning).

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB